1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

testing MrMC 3.0.3

Old TestFlight threads
Locked
User avatar
amet
Team MrMC
Posts: 2756
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: testing MrMC 3.0.3

Post by amet » 13 Apr 2017, 16:23

Thanks for the feedback, I'll have a look at the login by username. I do wonder if we need that at all, don't all emby users need to login via emby website?

User avatar
davilla
Team MrMC
Posts: 4078
Joined: 26 Oct 2015, 17:01

Re: testing MrMC 3.0.3

Post by davilla » 13 Apr 2017, 17:30

KeyserSoze wrote:
13 Apr 2017, 12:46
So I did a little testing with Emby but didn't get much of a chance to really put it through it's paces. Here's a few notes...

1. Emby via PIN worked fine for me and all Videos seemed to show up appropriately.
2. I could not get manual sign in to work but it's probably just me not understanding some piece.
- I browsed and found the lan server. It then filled out the Server Address and Shared Folder pieces.
- I tried leaving the Username blank and trying to use one of the Accounts specified in emby but when I press ok it goes back to the Emby Service Settings screen but it shows I still need to sign-in.

I'll post if I find anything else.
For Emby user/pass, user/pass cannot be left blank. How can it login if those are blank ?

KeyserSoze
Posts: 22
Joined: 13 Sep 2016, 17:37

Re: testing MrMC 3.0.3

Post by KeyserSoze » 13 Apr 2017, 17:40

davilla wrote:
13 Apr 2017, 17:30
For Emby user/pass, user/pass cannot be left blank. How can it login if those are blank ?
You are correct. I am assuming this is the User account on the local Emby server correct? My users don't have passwords on my local server. So I left it blank. Maybe having no password is causing the issue?

On the Emby Apps usually you select the server and then it prompts you which User you want to login with. If there is no password set it just logs in immediately.

User avatar
Msan2000
Posts: 26
Joined: 22 Mar 2017, 16:00

Re: testing MrMC 3.0.3

Post by Msan2000 » 14 Apr 2017, 02:42

Sorry, couldn't test as I was away on business all week.

I can login to my emby server with either manual or PIN.
On the main menu it populates and shows me entries for Movies and TV
When I click on either the Movies or TV Shows menu, I get the following display:
for Movies:
EMBY(0) - TOWER - ANIME MOVIES
EMBY(0) - TOWER - MOVIES
for TV:
EMBY(0) - TOWER - ANIME SERIES
EMBY(0) - TOWER - TV

When I highlight any of those entries it shows me 4 thumbnails that would be in that section.
But when I try to enter any of those sections I get:
Remote Share - Couldn't connect to network server

I checked the debug log and there is not much in there.. like:

Code: Select all

19:24:10 T:137954849872   DEBUG: CServicesDirectory::GetDirectory
19:24:10 T:137954849872   DEBUG: CServicesDirectory::GetDirectory strURL = services://tvshows/titles/
19:24:10 T:138384741456   DEBUG: CEmbyDirectory::GetDirectory
19:24:10 T:138384741456   DEBUG: CEmbyDirectory::GetDirectory strURL = emby://tvshows/titles/
19:24:10 T:138384741456   DEBUG: CEmbyDirectory::GetDirectory client(Tower), title(Emby(O) - Tower - TV )
19:24:10 T:138384741456   DEBUG: CEmbyDirectory::GetDirectory client(Tower), title(Emby(O) - Tower - Anime Series )
19:24:12 T:137954849872   DEBUG: Keyboard: scancode: 0x14, sym: 0x0112, unicode: 0x0000, modifier: 0x0
19:24:12 T:137954849872   DEBUG: OnKey: down (0xf081) pressed, action is Down
19:24:13 T:137954849872   DEBUG: Keyboard: scancode: 0x17, sym: 0x000d, unicode: 0x0000, modifier: 0x0
19:24:13 T:137954849872   DEBUG: OnKey: return (0xf00d) pressed, action is Select
19:24:13 T:138338604112   DEBUG: CEmbyDirectory::GetDirectory
19:24:13 T:138338604112   DEBUG: CEmbyDirectory::GetDirectory strURL = emby://tvshows/titles/aHR0cDovLzE5Mi4xNjguMjM0LjEwOjgwOTYvVXNlcnMvZjEzYjBlNzM2NDUyNGE1ZmJiNDI4MGRmMzE2YTliODEvSXRlbXM/UGFyZW50SWQ9NDUxNGVjODUwZTVhZDBjNDdiNTg0NDRlMTdiNjM0NmN8JlgtTWVkaWFCcm93c2VyLVRva2VuPWQzZWNkNGNiZmMzYTRkNzNhYWI1ODI3MjI2YmZmOWU1
19:24:13 T:138338604112   DEBUG: CEmbyDirectory::GetDirectory no client or client not present emby://tvshows/titles/aHR0cDovLzE5Mi4xNjguMjM0LjEwOjgwOTYvVXNlcnMvZjEzYjBlNzM2NDUyNGE1ZmJiNDI4MGRmMzE2YTliODEvSXRlbXM/UGFyZW50SWQ9NDUxNGVjODUwZTVhZDBjNDdiNTg0NDRlMTdiNjM0NmN8JlgtTWVkaWFCcm93c2VyLVRva2VuPWQzZWNkNGNiZmMzYTRkNzNhYWI1ODI3MjI2YmZmOWU1
19:24:13 T:137954849872   ERROR: GetDirectory - Error getting emby://tvshows/titles/aHR0cDovLzE5Mi4xNjguMjM0LjEwOjgwOTYvVXNlcnMvZjEzYjBlNzM2NDUyNGE1ZmJiNDI4MGRmMzE2YTliODEvSXRlbXM/UGFyZW50SWQ9NDUxNGVjODUwZTVhZDBjNDdiNTg0NDRlMTdiNjM0NmN8JlgtTWVkaWFCcm93c2VyLVRva2VuPWQzZWNkNGNiZmMzYTRkNzNhYWI1ODI3MjI2YmZmOWU1
19:24:13 T:137954849872   ERROR: CGUIMediaWindow::GetDirectory(emby://tvshows/titles/aHR0cDovLzE5Mi4xNjguMjM0LjEwOjgwOTYvVXNlcnMvZjEzYjBlNzM2NDUyNGE1ZmJiNDI4MGRmMzE2YTliODEvSXRlbXM/UGFyZW50SWQ9NDUxNGVjODUwZTVhZDBjNDdiNTg0NDRlMTdiNjM0NmN8JlgtTWVkaWFCcm93c2VyLVRva2VuPWQzZWNkNGNiZmMzYTRkNzNhYWI1ODI3MjI2YmZmOWU1) failed
I made a recording that might explain this better:
https://drive.google.com/file/d/0B_JMHr ... sp=sharing

User avatar
amet
Team MrMC
Posts: 2756
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: testing MrMC 3.0.3

Post by amet » 14 Apr 2017, 06:29

Could you post the full log to pastebin please

User avatar
Msan2000
Posts: 26
Joined: 22 Mar 2017, 16:00

Re: testing MrMC 3.0.3

Post by Msan2000 » 14 Apr 2017, 16:31

amet wrote:
14 Apr 2017, 06:29
Could you post the full log to pastebin please
As requested:

https://pastebin.com/g0pFgCAf

User avatar
amet
Team MrMC
Posts: 2756
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: testing MrMC 3.0.3

Post by amet » 14 Apr 2017, 16:59

Msan2000 wrote:
14 Apr 2017, 16:31
amet wrote:
14 Apr 2017, 06:29
Could you post the full log to pastebin please
As requested:

https://pastebin.com/g0pFgCAf
is the result the same if you login using user/pass and PIN?

User avatar
Msan2000
Posts: 26
Joined: 22 Mar 2017, 16:00

Re: testing MrMC 3.0.3

Post by Msan2000 » 14 Apr 2017, 17:07

amet wrote:
14 Apr 2017, 16:59
Msan2000 wrote:
14 Apr 2017, 16:31
amet wrote:
14 Apr 2017, 06:29
Could you post the full log to pastebin please
As requested:

https://pastebin.com/g0pFgCAf
is the result the same if you login using user/pass and PIN?
Yes, I had it with User/Pass first and when that didnt work I used PIN with the same result.

What is strange is that it seems to be able to access the server, as it displays the categories and thumbnails

User avatar
amet
Team MrMC
Posts: 2756
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: testing MrMC 3.0.3

Post by amet » 14 Apr 2017, 17:11

definitely odd, any chance you can link me to your server as "friend"? I would love to see if i can reproduce here as all our test cases are fine.. if you can, please send us a mail on support@mrmc.tv

EDIT: also looks like you are getting recently added, is that correct? do the items play fine from there?

User avatar
Msan2000
Posts: 26
Joined: 22 Mar 2017, 16:00

Re: testing MrMC 3.0.3

Post by Msan2000 » 14 Apr 2017, 17:47

amet wrote:
14 Apr 2017, 17:11
definitely odd, any chance you can link me to your server as "friend"? I would love to see if i can reproduce here as all our test cases are fine.. if you can, please send us a mail on support@mrmc.tv

EDIT: also looks like you are getting recently added, is that correct? do the items play fine from there?
I have to step out here for a bit, I can add you after.. EDIT: Invite sent..

I just tried the recently added (both movies and TV) and it plays fine from there..

Latest log with that .. https://pastebin.com/8btrwrAN

Locked