1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

libtool error when building

Development talk only
Post Reply
bikeseat
Posts: 3
Joined: 31 Jan 2019, 05:22

libtool error when building

Post by bikeseat » 17 Feb 2019, 09:55

Building mrmc for tvos on macos 10.13.6.

When making after running these commands:

Code: Select all

cd $HOME
git clone git://github.com/mrmc/mrmc.git MrMC
cd $HOME/MrMC
cd tools/depends
./bootstrap
./configure --host=arm-apple-darwin --with-cpu=arm64 --with-platform=tvos
make
I would get the same error from libtool regarding a version mismatch. This must have happened nearly a dozen times.

Couldn't figure out how to properly handle it, so at every instance, I commented out the function call for "func_check_version_match" in the libtool file in the build directory, for example: "libflac/appletvos12.1_arm64-target/libtool"

I did try autoreconf and similar to no avail, but even if that worked, I would have had to run it each time after the libtool version mismatch error caused making to die.

What is the proper way to handle this? Is there a problem with the build scripts?

Snipped for brevity:

Code: Select all

config.status: executing libtool commands
/Applications/Xcode.app/Contents/Developer/usr/bin/make -j 1 -C appletvos12.1_arm64-target/src
/bin/sh ../libtool --tag=CXX   --mode=compile /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -DHAVE_CONFIG_H -I. -I.. -I../include  -fheinous-gnu-extensions -no-cpp-precomp -fembed-bitcode -ftree-vectorize -pipe -Wno-trigraphs -fpascal-strings -O3 -Wreturn-type -Wunused-variable -fmessage-length=0 -gdwarf-2 -Wno-error=implicit-function-declaration -arch arm64 -mappletvos-version-min=10.2  -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/AppleTVOS.platform/Developer/SDKs/AppleTVOS12.1.sdk -isystem /Users/Shared/mrmc-depends/appletvos12.1_arm64-target/include   -DTIXML_USE_STL -no-cpp-precomp -fembed-bitcode  -arch arm64 -mappletvos-version-min=10.2 -std=c++11 -stdlib=libc++ -g -O2 -std=c++11 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/AppleTVOS.platform/Developer/SDKs/AppleTVOS12.1.sdk -isystem /Users/Shared/mrmc-depends/appletvos12.1_arm64-target/include  -MT tinystr.lo -MD -MP -MF .deps/tinystr.Tpo -c -o tinystr.lo tinystr.cpp
libtool: Version mismatch error.  This is libtool 2.4.6, revision 2.4.6,
libtool: but the definition of this LT_INIT comes from revision .
libtool: You should recreate aclocal.m4 with macros from revision 2.4.6
libtool: of libtool 2.4.6 and run autoconf again.
make[3]: *** [tinystr.lo] Error 63
make[2]: *** [appletvos12.1_arm64-target/src/.libs/libtinyxml.a] Error 2
make[1]: *** [tinyxml] Error 2
make: *** [target/.installed-appletvos12.1_arm64-target] Error 2
~/mrmc/tools/depends ❯

User avatar
davilla
Team MrMC
Posts: 3868
Joined: 26 Oct 2015, 17:01

Re: libtool error when building

Post by davilla » 17 Feb 2019, 15:22

which Xcode version ?

bikeseat
Posts: 3
Joined: 31 Jan 2019, 05:22

Re: libtool error when building

Post by bikeseat » 19 Feb 2019, 04:29

Version 10.1 (10B61)

User avatar
davilla
Team MrMC
Posts: 3868
Joined: 26 Oct 2015, 17:01

Re: libtool error when building

Post by davilla » 19 Feb 2019, 16:22

This is my build of libflac after make distclean in that dir

https://pastebin.com/YuTjZjcn

Same xcode/osx version as you.

Post Reply