Page 1 of 2

Rollback to 3.4 possible?

Posted: 01 Apr 2018, 17:34
by mkc2lr
Hello,

I was really happy with 3.4, since then things went really bad. First the changed control which is not fully possible to be changed back and now with 3.6 audio passthrough doesn‘t work anymore. My amp recognizes only stereo no matter if it‘s ac or dts. The movie I started yesterday which was perfectly fine is not possible today. Both with tvos 11.3

Thus I‘d like to roll back to 3.4 if this is possible. I don’t need any other functions than already implemented. Just for picture quality I‘d update. There‘s a lot room for improvement....

Any hints how to go back? I‘m using the paid version on an atv4k.

Thanks,
Christof

Re: Rollback to 3.4 possible?

Posted: 01 Apr 2018, 17:50
by davilla
mkc2lr wrote:
01 Apr 2018, 17:34
Hello,

I was really happy with 3.4, since then things went really bad. First the changed control which is not fully possible to be changed back and now with 3.6 audio passthrough doesn‘t work anymore. My amp recognizes only stereo no matter if it‘s ac or dts. The movie I started yesterday which was perfectly fine is not possible today. Both with tvos 11.3

Thus I‘d like to roll back to 3.4 if this is possible. I don’t need any other functions than already implemented. Just for picture quality I‘d update. There‘s a lot room for improvement....

Any hints how to go back? I‘m using the paid version on an atv4k.

Thanks,
Christof
Nope, Apple does not permit app version rollbacks.

tvos 11.3 broke passthrough, known issue during the beta's for it. Everyone was warned.

"the changed control which is not fully possible to be changed back", sorry, not a clue what that means.

Re: Rollback to 3.4 possible?

Posted: 01 Apr 2018, 18:30
by mkc2lr
Thanks davilla for the quick answer. At least I found now that if I disable passthrough I get sound again.
The control issue is the changed control between 3.4 and 3.5 in the atv version allowing to use the touchpad for start/stop, etc. I hate that and found that you can disable it, but in some situations, still the menu doesn’t come up and also skip steps are not configurable properly.

Now I also found a new problem: 4k Videos can‘t be played with AV foundation acceleration any more. If I try, the picture is far too bright and yellowish. Maybe related to tvos 11.3? Or also the 3.6 update?

Christof

Re: Rollback to 3.4 possible?

Posted: 01 Apr 2018, 19:00
by cosmoxl
mkc2lr wrote:
01 Apr 2018, 18:30
Thanks davilla for the quick answer. At least I found now that if I disable passthrough I get sound again.
The control issue is the changed control between 3.4 and 3.5 in the atv version allowing to use the touchpad for start/stop, etc. I hate that and found that you can disable it, but in some situations, still the menu doesn’t come up and also skip steps are not configurable properly.

Now I also found a new problem: 4k Videos can‘t be played with AV foundation acceleration any more. If I try, the picture is far too bright and yellowish. Maybe related to tvos 11.3? Or also the 3.6 update?

Christof
tvOS was doing the necessary conversions to make HDR content to look proper with SDR output with AVF as decoder in tvOS 11.2.x. In 11.3 it's not working anymore. Bad for us without HDR TVs. This isn't a MrMC thing.

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 00:14
by Gizmo5000
HI. I had the same problem regarding the overly bright and yellow 4K movies after ATV's 11.3 update. Apples update turns off the "Match Content" settings for some reason. Set both the Range and Framerate in the ATV's settings back to on. You can keep using the "AVFoundation" for x265 decoding.

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 00:49
by cosmoxl
Gizmo5000 wrote:
03 Apr 2018, 00:14
HI. I had the same problem regarding the overly bright and yellow 4K movies after ATV's 11.3 update. Apples update turns off the "Match Content" settings for some reason. Set both the Range and Framerate in the ATV's settings back to on. You can keep using the "AVFoundation" for x265 decoding.
Are you playing to an HDR TV?

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 04:17
by Gizmo5000
Yes

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 04:23
by Gizmo5000
cosmoxl wrote:
03 Apr 2018, 00:49
Gizmo5000 wrote:
03 Apr 2018, 00:14
HI. I had the same problem regarding the overly bright and yellow 4K movies after ATV's 11.3 update. Apples update turns off the "Match Content" settings for some reason. Set both the Range and Framerate in the ATV's settings back to on. You can keep using the "AVFoundation" for x265 decoding.
Are you playing to an HDR TV?
Yes

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 19:25
by mkc2lr
Both options were not turned off in my case. This is not the cause, I guess.
But I‘m playing on a SDR TV.

Re: Rollback to 3.4 possible?

Posted: 03 Apr 2018, 19:40
by cosmoxl
mkc2lr wrote:
03 Apr 2018, 19:25
Both options were not turned off in my case. This is not the cause, I guess.
But I‘m playing on a SDR TV.
Yep, stinks that apple removed the conversion to SDR that was working prior to 11.3