1. No user installed addons are supported, python or otherwise.
2. No, they really are not supported.
3. They are not coming back
4. Read from 1. again

Any mention of illegal streaming sites, addons or any pirated material will not be tolerated. This is not democracy and any offenders will be banned and posts deleted immediately without warning.

Other than that, we hope you enjoy MrMC so far and we welcome any input and feedback you might have.

Team MrMC.

MrMC fails STRM playback

Google Play Store and App Store beta test feedback
User avatar
Montoya
Posts: 364
Joined: 27 Sep 2017, 22:46

MrMC fails STRM playback

Post by Montoya » 12 Apr 2019, 09:59

This topic ONLY applies to tvOS AND iOS MrMC clients.

MrMC FAILS strm playback from my Provider A when:
- strm played from Video Media Source MrMC
- strm played from File Manager MrMC
- strm played from Emby Client Service as movie (Emby strm movie library)

MrMC does NOT fail playback for my Provider A when:
- m3u (with same stream URL's from what's inside those strm that fail playback), loaded into MrMC PVR Simple Client.

I also have Provider B and that one has NO problems in whatever MrMC scenario with strm playback.

Provider A has NO problems playing strm on the following platforms on my Home network with:
- VLC when loading stream URL directly from strm (tvOS, iOS, PC)
- Kodi (PC)
- Emby (PC)

So to me, this still seems an MrMC problem, that can't handle the changes Provider A has done for stream play of strm.

@devs, for testing the above, you don't need Emby access to my Emby server, because when above issues are fixed, Emby Client service will also work for playback of my strm based Emby libraries.

For testing, you already have an m3u and strm files in your mailbox (mail dated march 9th 2019)
Apple TV 4K 64GB tvOS 12.4 - Win10 Pro x64 1903 build 18362.264
DVBLink Server 6.0.0 build14499 - TVMosaic Server build 17679 - Emby Server build 4.2.0.1 beta

User avatar
davilla
Team MrMC
Posts: 4089
Joined: 26 Oct 2015, 17:01

Re: MrMC fails STRM playback

Post by davilla » 12 Apr 2019, 11:51

which kodi ?

User avatar
Montoya
Posts: 364
Joined: 27 Sep 2017, 22:46

Re: MrMC fails STRM playback

Post by Montoya » 12 Apr 2019, 12:52

davilla wrote:
12 Apr 2019, 11:51
which kodi ?

Code: Select all

2019-04-12 14:50:07.114 T:16656  NOTICE: Starting Kodi (18.1 Git:20190217-8cfdc895f3). Platform: Windows NT x86 64-bit
2019-04-12 14:50:07.114 T:16656  NOTICE: Using Release Kodi x64 build
2019-04-12 14:50:07.114 T:16656  NOTICE: Kodi compiled 2019-02-17 by MSVC 191627026 for Windows NT x86 64-bit version 10.0 (0x0A000006)
2019-04-12 14:50:07.114 T:16656  NOTICE: Running on Windows 10, kernel: Windows NT x86 64-bit version 10.0.17763
Apple TV 4K 64GB tvOS 12.4 - Win10 Pro x64 1903 build 18362.264
DVBLink Server 6.0.0 build14499 - TVMosaic Server build 17679 - Emby Server build 4.2.0.1 beta

User avatar
davilla
Team MrMC
Posts: 4089
Joined: 26 Oct 2015, 17:01

Re: MrMC fails STRM playback

Post by davilla » 13 Apr 2019, 15:31

fixed :)

User avatar
Montoya
Posts: 364
Joined: 27 Sep 2017, 22:46

Re: MrMC fails STRM playback

Post by Montoya » 13 Apr 2019, 15:36

Wow, really ? :mrgreen:

That makes me and my family very very happy, so looking forward to it :!: :!: :D :D
Curious to know what magic you did, preferably by email, in case provider A reads here ;)
Apple TV 4K 64GB tvOS 12.4 - Win10 Pro x64 1903 build 18362.264
DVBLink Server 6.0.0 build14499 - TVMosaic Server build 17679 - Emby Server build 4.2.0.1 beta

User avatar
davilla
Team MrMC
Posts: 4089
Joined: 26 Oct 2015, 17:01

Re: MrMC fails STRM playback

Post by davilla » 13 Apr 2019, 16:00

Montoya wrote:
13 Apr 2019, 15:36
Wow, really ? :mrgreen:

That makes me and my family very very happy, so looking forward to it :!: :!: :D :D
Curious to know what magic you did, preferably by email, in case provider A reads here ;)
If you check your server logs, you will notice someone from the USA using it :)

The issue was MrMC was doing a HEAD request for mime-type, which failed, followed immediately by request for the content. The content 502'ed and failed. Strangely it worked fine when stepping through the code.

The fix was to pull in https://github.com/xbmc/xbmc/pull/9504, which has a side effect of moving the mime-type request much earlier.

So something about fast back-to-back requests to the proxy server. Maybe some sort of DDOS protection ?

User avatar
Montoya
Posts: 364
Joined: 27 Sep 2017, 22:46

Re: MrMC fails STRM playback

Post by Montoya » 13 Apr 2019, 16:35

davilla wrote:
13 Apr 2019, 16:00
Montoya wrote:
13 Apr 2019, 15:36
Wow, really ? :mrgreen:

That makes me and my family very very happy, so looking forward to it :!: :!: :D :D
Curious to know what magic you did, preferably by email, in case provider A reads here ;)
If you check your server logs, you will notice someone from the USA using it :)

The issue was MrMC was doing a HEAD request for mime-type, which failed, followed immediately by request for the content. The content 502'ed and failed. Strangely it worked fine when stepping through the code.

The fix was to pull in https://github.com/xbmc/xbmc/pull/9504, which has a side effect of moving the mime-type request much earlier.

So something about fast back-to-back requests to the proxy server. Maybe some sort of DDOS protection ?
Who is knocking on my door :D

Have you spoofed my set of external IP's that are allowed on my Emby server ;) ?
I guess not, but you never know, you have a direct connection to my provider now with those strm and m3u :)
Enjoy now, you can also use them when it is bedtime in my timezone (can send complete m3u if you want, have enough connections for that, but only when it is past midnight in my timezone (UTC/GMT +2) :)

Glad that you have found the issue that quickly, so thanks again :D

PS: You can do an Emby test with a connection to my Emby server to test the MrMC change.
Have whitelisted your IP to my Emby server and Cloudflare already, if you have a fixed IP (if not, provide subnet or AS number by email, than I will add it)
Knocking_on_myDoor.png
Apple TV 4K 64GB tvOS 12.4 - Win10 Pro x64 1903 build 18362.264
DVBLink Server 6.0.0 build14499 - TVMosaic Server build 17679 - Emby Server build 4.2.0.1 beta

User avatar
amet
Team MrMC
Posts: 2763
Joined: 26 Oct 2015, 16:59
Location: Dubai/Novi Sad

Re: MrMC fails STRM playback

Post by amet » 13 Apr 2019, 19:21

fix is in 3.8.1, have you tried Emby server or IPTV strm file?

User avatar
Montoya
Posts: 364
Joined: 27 Sep 2017, 22:46

Re: MrMC fails STRM playback

Post by Montoya » 13 Apr 2019, 20:28

Still testing and I don't know what to say.
What I did:

First tested new TF with my existing profiles, it "looked" like no improvement, but there is (see text after new install MrMC). So same symptoms as before.

But again, loading the m3u (with same stream URLs from strm) in MrMC PVR Simple Client, a movie always plays with one click (from PVR).

Removed MrMC completely, to see if it that made a difference, because of all my MrMC profiles I have for a long time already.

With fresh MrMC install, created new profiles again, all with seperate Media info/sources and with a copy from a clean default settings/clean default sources.

(noticed still a bug there, when logging into just new created profile, from login screen, that hangs MrMC in blacks screen, but only on first login into fresh profile AND when the Master profile is still on default settings AND has no sources added. Second login works directly)

STRM test:
In new profile, added SMB Video Media source where my strm files are.
When I click a strm movie, it doesn't play directly... but when I do a SLOW double click, the movie always plays :D
This is with "default select action" on play and with default "internet access" settings.

Emby test:
In Emby,single click always fails playback, the "strm double click trick" for play, needs a quadruple click in Emby, for the movie to eventually play (maybe the difference for accessing my Emby server for the URL).

Tested also with local Emby access and https access to external domain, with Apple TV 4K on LAN or WIFI, to see if that made a difference, but it did not.
(Edit: I see slightly better results with WIFI, maybe because of the latency ?)

DNS I'm using now is Cloudflares 1.1.1.1.

Before you guys do anything, I want to take my Apple TV 4K to my brothers house, who has a different ISP.
Also want to test another router, to see if mine has DNS problems, because I have a lot of devices running on it.

Or if you guys don't have the same problems I experience on the Apple TV, than I suspect my ISP or router, instead of MrMC.

If above ring any bells with you guys, or want to see some logs, tell me which log settings you want the log to be in and I will provide them.

@Amet, if you want direct acces to my Emby server, send me email with your subnet/AS number or IP, so I can whitelist you in CLoudflare and Emby (Davilla's IP, I have already in whitelist). Also if you need some m3u's or strm with lower bandwidth instead of the 4K ones, you already have.
Last edited by Montoya on 13 Apr 2019, 21:03, edited 1 time in total.
Apple TV 4K 64GB tvOS 12.4 - Win10 Pro x64 1903 build 18362.264
DVBLink Server 6.0.0 build14499 - TVMosaic Server build 17679 - Emby Server build 4.2.0.1 beta

User avatar
davilla
Team MrMC
Posts: 4089
Joined: 26 Oct 2015, 17:01

Re: MrMC fails STRM playback

Post by davilla » 13 Apr 2019, 21:01

odd, I just took those xxx.strm files you emailed, put them on my NAS and browse and click on one.

Post Reply